HCLA静态综合实验

一.设计要求

1.除R5的环回地址固定以外,整个其他所有网端基于192.168.1.0/24进行合理的IP地址划分。
2.R1-R4每个路由器存在两个环回路口,用于模拟连接PC网段;地址也在192.168.1.0/24这个网络范围内。
3.R1-R4上不能直接编写达到5.5.5.0/24的静态路由,但依然可以访问。
4.全网可达,尽量减少每台路由器,路由表条目数量,避免环路出现。
5.R4与R5间,正常1000M链路通信,故障时自动改为100M。
 

二.具体步骤

1.子网划分

192.168.1.0/24  划两个,借一位   一个分给主网段,一个分为环回
192.168.1.0/25 主网段  分为六个,借三位
192.168.1.0 000 0000  192.168.1.0/28   R1-R2
192.168.1.0 001 0000  192.168.1.16/28  R2-R4
192.168.1.0 010 0000  192.168.1.32/28  R1-R3
192.168.1.0 011 0000  192.168.1.48/28  R3-R4
192.168.1.0 100 0000  192.168.1.64/28   R4-R5 100M
192.168.1.0 101 0000  192.168.1.80/28   R4-R5 1000M
192.168.1.0 110 0000  192.168.1.96/28
192.168.1.0 111 0000  192.168.1.112/28


192.168.1.128/25  环回 八个环回,借三位
192.168.1.1 000 0000  192.168.1.128/28   R1
192.168.1.1 001 0000  192.168.1.144/28
192.168.1.1 010 0000  192.168.1.160/28   R2
192.168.1.1 011 0000  192.168.1.176/28
192.168.1.1 100 0000  192.168.1.192/28   R3
192.168.1.1 101 0000  192.168.1.208/28   
192.168.1.1 110 0000  192.168.1.224/28   R4
192.168.1.1 111 0000  192.168.1.240/28

2.配置IP及环回

R1:

[R1]interface g0/0/0
[R1-GigabitEthernet0/0/0]ip address 192.168.1.1 28
[R1-GigabitEthernet0/0/0]q
[R1]interface g0/0/1
[R1-GigabitEthernet0/0/1]ip address 192.168.1.33 28
[R1-GigabitEthernet0/0/1]q 
[R1]interface LoopBack 0 
[R1-LoopBack0]ip address 192.168.1.129 28
[R1-LoopBack0]q 
[R1]interface LoopBack 1
[R1-LoopBack1]ip address 192.168.1.145 28

R2:

[R2]interface LoopBack 0
[R2-LoopBack0]ip address 192.168.1.161 28
[R2-LoopBack0]q
[R2]interface LoopBack 1
[R2-LoopBack1]ip address 192.168.1.177 28
[R2-LoopBack1]q
[R2]interface g0/0/0
[R2-GigabitEthernet0/0/0]ip address 192.168.1.2 28
[R2-GigabitEthernet0/0/0]q
[R2]interface g0/0/1
[R2-GigabitEthernet0/0/1]ip address 192.168.1.17 28
[R2-GigabitEthernet0/0/1]q

R3:

[R3]interface LoopBack 0
[R3-LoopBack0]ip address 192.168.1.193 28
[R3-LoopBack0]q 
[R3]interface LoopBack 1
[R3-LoopBack1]ip address 192.168.1.209 28
[R3-LoopBack1]q
[R3]interface g0/0/0
[R3-GigabitEthernet0/0/0]ip address 192.168.1.34 28
[R3-GigabitEthernet0/0/0]q  
[R3]interface g0/0/1
[R3-GigabitEthernet0/0/1]ip address 192.168.1.49 28
[R3-GigabitEthernet0/0/1]q

R4:

[R4]interface LoopBack 0
[R4-LoopBack0]ip address 192.168.1.225 28
[R4-LoopBack0]q
[R4]interface LoopBack 1
[R4-LoopBack1]ip address 192.168.1.241 28
[R4-LoopBack1]q  
[R4]interface g0/0/0  
[R4-GigabitEthernet0/0/0]ip address 192.168.1.18 28
[R4-GigabitEthernet0/0/0]q
[R4]interface g0/0/1
[R4-GigabitEthernet0/0/1]ip address 192.168.1.50 28
[R4-GigabitEthernet0/0/1]q
[R4]interface g0/0/2 
[R4-GigabitEthernet0/0/2]ip address 192.168.1.65 28
[R4-GigabitEthernet0/0/2]q
[R4]interface g4/0/0
[R4-GigabitEthernet4/0/0]ip address 192.168.1.81 28
[R4-GigabitEthernet4/0/0]q

R5:

[R5]interface LoopBack 0
[R5-LoopBack0]ip address 5.5.5.1 24
[R5-LoopBack0]q
[R5]interface g0/0/0
[R5-GigabitEthernet0/0/0]ip address 192.168.1.66 28
[R5-GigabitEthernet0/0/0]q
[R5]interface g0/0/1   
[R5-GigabitEthernet0/0/1]ip address 192.168.1.82 28
[R5-GigabitEthernet0/0/1]q

3.R1-R4的静态路由配置

R1:

[R1]ip route-static 192.168.1.16 28 192.168.1.2
[R1]ip route-static 192.168.1.48 28 192.168.1.34
[R1]ip route-static 192.168.1.80 28 192.168.1.34
[R1]ip route-static 192.168.1.64 28 192.168.1.2
[R1]ip route-static 192.168.1.160 28 192.168.1.2

[R1]ip route-static 192.168.1.176 28 192.168.1.2

[R1]ip route-static 192.168.1.192 28 192.168.1.34
[R1]ip route-static 192.168.1.208 28 192.168.1.34
[R1]ip route-static 192.168.1.224 28 192.168.1.34
[R1]ip route-static 192.168.1.240 28 192.168.1.34
[R1]ip route-static 192.168.1.240 28 192.168.1.2
[R1]ip route-static 192.168.1.224 28 192.168.1.2

R2:

[R2]ip route-static 192.168.1.32 28 192.168.1.1
[R2]ip route-static 192.168.1.48 28 192.168.1.18
[R2]ip route-static 192.168.1.64 28 192.168.1.18
[R2]ip route-static 192.168.1.80 28 192.168.1.18
[R2]ip route-static 192.168.1.192 28 192.168.1.1
[R2]ip route-static 192.168.1.208 28 192.168.1.1

[R2]ip route-static 192.168.1.128 28 192.168.1.1
[R2]ip route-static 192.168.1.144 28 192.168.1.1
[R2]ip route-static 192.168.1.224 28 192.168.1.18
[R2]ip route-static 192.168.1.240 28 192.168.1.18

R3:

[R3]ip route-static 192.168.1.0 28 192.168.1.33
[R3]ip route-static 192.168.1.16 28 192.168.1.50
[R3]ip route-static 192.168.1.64 28 192.168.1.50
[R3]ip route-static 192.168.1.80 28 192.168.1.50
[R3]ip route-static 192.168.1.128 28 192.168.1.50
[R3]ip route-static 192.168.1.144 28 192.168.1.50
[R3]ip route-static 192.168.1.160 28 192.168.1.50
[R3]ip route-static 192.168.1.176 28 192.168.1.5
[R3]ip route-static 192.168.1.224 28 192.168.1.33
[R3]ip route-static 192.168.1.240 28 192.168.1.33

R4:

[R4]ip route-static 192.168.1.0 28 192.168.1.17
[R4]ip route-static 192.168.1.32 28 192.168.1.49
[R4]ip route-static 192.168.1.160 28 192.168.1.17
[R4]ip route-static 192.168.1.176 28 192.168.1.17
[R4]ip route-static 192.168.1.128 28 192.168.1.49
[R4]ip route-static 192.168.1.144 28 192.168.1.49
[R4]ip route-static 192.168.1.192 28 192.168.1.49
[R4]ip route-static 192.168.1.208 28 192.168.1.49

R5:

[R5]ip route-static 192.168.1.0 28 192.168.1.65
[R5]ip route-static 192.168.1.16 28 192.168.1.65
[R5]ip route-static 192.168.1.32 28 192.168.1.65
[R5]ip route-static 192.168.1.48 28 192.168.1.65
[R5]ip route-static 192.168.1.128 28 192.168.1.65
[R5]ip route-static 192.168.1.144 28 192.168.1.65
[R5]ip route-static 192.168.1.160 28 192.168.1.65
[R5]ip route-static 192.168.1.176 28 192.168.1.65
[R5]ip route-static 192.168.1.192 28 192.168.1.6
[R5]ip route-static 192.168.1.208 28 192.168.1.65
[R5]ip route-static 192.168.1.224 28 192.168.1.65
[R5]ip route-static 192.168.1.240 28 192.168.1.65

4.配置缺省路由

[R1]ip route-static 0.0.0.0 0 192.168.1.2
[R1]ip route-static 0.0.0.0 0 192.168.1.34

[R2]ip route-static 0.0.0.0 0 192.168.1.18

[R3]ip route-static 0.0.0.0 0 192.168.1.50

[R4]ip route-static 0.0.0.0 0 192.168.1.66
[R4]ip route-static 0.0.0.0 0 192.168.1.82

5.浮动静态路由

[R4]ip route-static 5.5.5.0 24 192.168.1.66 preference 66

热门文章

暂无图片
编程学习 ·

C语言二分查找详解

二分查找是一种知名度很高的查找算法,在对有序数列进行查找时效率远高于传统的顺序查找。 下面这张动图对比了二者的效率差距。 二分查找的基本思想就是通过把目标数和当前数列的中间数进行比较,从而确定目标数是在中间数的左边还是右边,将查…
暂无图片
编程学习 ·

GMX 命令分类列表

建模和计算操作命令: 1.1 . 创建拓扑与坐标文件 gmx editconf - 编辑模拟盒子以及写入子组(subgroups) gmx protonate - 结构质子化 gmx x2top - 根据坐标生成原始拓扑文件 gmx solvate - 体系溶剂化 gmx insert-molecules - 将分子插入已有空位 gmx genconf - 增加…
暂无图片
编程学习 ·

一文高效回顾研究生课程《数值分析》重点

数值分析这门课的本质就是用离散的已知点去估计整体,就是由黑盒子产生的结果去估计这个黑盒子。在数学里这个黑盒子就是一个函数嘛,这门课会介绍许多方法去利用离散点最大化地逼近这个函数,甚至它的导数、积分,甚至微分方程的解。…
暂无图片
编程学习 ·

在职阿里5年,一个28岁女软测工程师的心声

简单的先说一下,坐标杭州,14届本科毕业,算上年前在阿里巴巴的面试,一共有面试了有6家公司(因为不想请假,因此只是每个晚上去其他公司面试,所以面试的公司比较少) ​ 编辑切换为居中…
暂无图片
编程学习 ·

字符串左旋c语言

目录 题目: 解题思路: 第一步: 第二步: 第三步: 总代码: 题目: 实现一个函数,可以左旋字符串中的k个字符。 例如: ABCD左旋一个字符得到BCDA ABCD左旋两个字符…
暂无图片
编程学习 ·

设计模式--观察者模式笔记

模式的定义与特点 观察者(Observer)模式的定义:指多个对象间存在一对多的依赖关系,当一个对象的状态发生改变时,所有依赖于它的对象都得到通知并被自动更新。这种模式有时又称作发布-订阅模式、模型-视图模式&#xf…
暂无图片
编程学习 ·

睡觉突然身体动不了,什么是睡眠痽痪症

很多朋友可能有这样的体验,睡觉过程中突然意识清醒,身体却动弹不了。这时候感觉非常恐怖,希望旁边有一个人推自己一下。阳光以前也经常会碰到这样的情况,一年有一百多次,那时候很害怕晚上到来,睡觉了就会出…
暂无图片
编程学习 ·

深入理解C++智能指针——浅析MSVC源码

文章目录unique_ptrshared_ptr 与 weak_ptrstd::bad_weak_ptr 异常std::enable_shared_from_thisunique_ptr unique_ptr 是一个只移型别(move-only type,只移型别还有std::mutex等)。 结合一下工厂模式,看看其基本用法&#xff…
暂无图片
编程学习 ·

@TableField(exist = false)

TableField(exist false) //申明此字段不在数据库存在,但代码中需要用到它,通知Mybatis-plus在做写库操作是忽略它。,.
暂无图片
编程学习 ·

Java Web day15

第十二章文件上传和下载 一、如何实现文件上传 要实现Web开发中的文件上传功能,通常需要完成两步操作:一.是在Web页面中添加上传输入项;二是在Servlet中读取上传文件的数据,并保存到本地硬盘中。 需要使用一个Apache组织提供一个…
暂无图片
编程学习 ·

【51nod 2478】【单调栈】【前缀和】小b接水

小b接水题目解题思路Code51nod 2478 小b接水 题目 输入样例 12 0 1 0 2 1 0 1 3 2 1 2 1输出样例 6解题思路 可以发现最后能拦住水的都是向两边递减高度(?) 不管两个高积木之间的的积木是怎样乱七八糟的高度,最后能用来装水的…
暂无图片
编程学习 ·

花了大半天写了一个UVC扩展单元调试工具

基于DIRECTSHOW 实现的,用的是MFC VS2019. 详见:http://www.usbzh.com/article/detail-761.html 获取方法 加QQ群:952873936,然后在群文件\USB调试工具&测试软件\UVCXU-V1.0(UVC扩展单元调试工具-USB中文网官方版).exe USB中文网 USB中文…
暂无图片
编程学习 ·

贪心(一):区间问题、Huffman树

区间问题 例题一:区间选点 给定 N 个闭区间 [ai,bi]请你在数轴上选择尽量少的点,使得每个区间内至少包含一个选出的点。 输出选择的点的最小数量。 位于区间端点上的点也算作区间内。 输入格式 第一行包含整数 N,表示区间数。 接下来 …
暂无图片
编程学习 ·

C语言练习实例——费氏数列

目录 题目 解法 输出结果 题目 Fibonacci为1200年代的欧洲数学家,在他的着作中曾经提到:「若有一只免子每个月生一只小免子,一个月后小免子也开始生产。起初只有一只免子,一个月后就有两只免子,二个月后有三只免子…
暂无图片
编程学习 ·

Android开发(2): Android 资源

个人笔记整理 Android 资源 Android中的资源,一般分为两类: 系统内置资源:Android SDK中所提供的已经定义好的资源,用户可以直接拿来使用。 用户自定义资源:用户自己定义或引入的,只适用于当前应用的资源…
暂无图片
编程学习 ·

零基础如何在短时间内拿到算法offer

​算法工程师是利用算法处理事物的职业 算法(Algorithm)是一系列解决问题的清晰指令,也就是说,能够对一定规范的输入,在有限时间内获得所要求的输出。 如果一个算法有缺陷,或不适合于某个问题,执…
暂无图片
编程学习 ·

人工智能:知识图谱实战总结

人工智能python,NLP,知识图谱,机器学习,深度学习人工智能:知识图谱实战前言一、实体建模工具Protegepython,NLP,知识图谱,机器学习,深度学习 人工智能:知识图…
暂无图片
编程学习 ·

【无标题】

这里写自定义目录标题欢迎使用Markdown编辑器新的改变功能快捷键合理的创建标题,有助于目录的生成如何改变文本的样式插入链接与图片如何插入一段漂亮的代码片生成一个适合你的列表创建一个表格设定内容居中、居左、居右SmartyPants创建一个自定义列表如何创建一个注…